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1 Общие сведения

В данном документе рассмотрен процесс сборки и запуска тестовой программы передачи данных по шине
PCIe между двумя модулями SAMC-403 через PCIe коммутатор.

Предполагается, что в тестовой системе установлен центральный коммутатор SMCH-100-PE производства
компании Scan Engineering Telecom в состав которого входит PCIe коммутатор PEX8648.

Схема соединения двух модулей SAMC-403 через коммутатор SMCH-100-PE показана на рисунке 1-1. Те-
стовая программа запускается на обоих модулях SAMC-403. В программе, которая запускается на модуле
RC, реализован код перечислителя шины PCIe, который находит второй модуль EP на шине и конфигу-
рирует все необходимые окна памяти на PCI-мосту коммутатора для возможности прохождения данных.

Рисунок 1-1: Схема соединения модулей SAMC-403 через коммутатор SMCH-100-PE

Код перечислителя шины PCIe был проверен только на PCIe коммутаторе PEX8648. Поэтому, для пра-
вильной работы тестовой программы, рекомендуется использовать в качестве центрального коммутатора
именно SMCH-100-PE.

Для сборки и запуска тестовой программы потребуется установленная система разработки CCS (Code
Composer Studio). Сборка и запуск тестовой программы были проверены на CCS версии 5.2.0.00069 под
Windows систему. Дистрибутив CCS версии 5.2.0.00069 для Windows и Linux систем можно найти на сопро-
водительном диске к модулю SAMC-403 в папке «software/ccs».

Тестовая программа написана на основе кода демонстрационного примера работы с PCIe из библиотеки TI
PDK для DSP C6678.
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2 Сборка проекта тестовой программы

Для сборки проекта тестовой программы необходима установленная библиотека MCSDK (MultiCore
Software Development Kit) компании TI. Сборка проекта проверялась с библиотекой MCSDK версии
2.00.08.20, дистрибутив которой имеется на сопроводительном диске к модулю SAMC-403 в папке
«software/ccs/mcsdk».

2.1 Создание рабочего пространства
Для сборки проекта в CCS необходимо импортировать и собрать проект тестовой программы в среду раз-
работки.

Перед импортом проекта в CCS рекомендуется создать новое рабочее пространство (workspace). Для этого,
в запущенной среде разработки CCS, выберите пункт меню «File > Switch Workspace > Other...» (см. рису-
нок 2-1).

Рисунок 2-1: Смена рабочего пространства (workspace) в CCS

В открывшемся окне (рисунок 2-2) выберите папку нового рабочего пространства. Например, можно исполь-
зовать папку «D:/PCIE/Workspace_RC».

Рисунок 2-2: Выбор папки для рабочего пространства (workspace) в CCS
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Нажмите на кнопку «OK». Среда CCS будет перезапущена с новым рабочим пространством. После запуска
можно будет увидеть окно, аналогичное показанному на рисунке 2-3.

Рисунок 2-3: Главное окно среды CCS после запуска в новом рабочем пространстве
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2.2 Импорт проекта
Перепишите файлы проекта тестовой программы с сопроводительного диска к модулю SAMC-403 на жест-
кий диск компьютера. Исходные коды проекта тестовой программы можно найти на сопроводительном дис-
ке к модулю SAMC-403 в папке «pcie/PCIE_exampleProject». Далее, предполагается, что папка проекта те-
стовой программы «PCIE_exampleProject» с сопроводительного диска была переписана на жесткий диск
компьютера в папку «D:/PCIE».

Нажмите на кнопку «Import Project» (на рисунке 2-3 выделено красным овалом). Откроется окно, показанное
на рисунке 2-4.

Рисунок 2-4: Окно импорта проекта Рисунок 2-5: Окно выбора папок файловой системы

Примечание

Окно импорта проектов, показанное на рисунке 2-3, можно вызвать через главное меню, выбрав пункт «File > Import...». В
открывшемся окне выбора типа проекта, нужно выбрать тип «Code Composer Studio > Existing CCS Eclipse rojects» и нажать
на кнопку «Next > ».

Нажмите на кнопку «Browse...». Откроется стандартное системное окно обзора папок файловой системы
(рисунок 2-5), в котором необходимо выбрать папку импортируемого проекта. В нашем случае, это должна
быть папка «D:/PCIE/PCIE_exampleProject». После выбора нужной папки, нажмите кнопку «OK».

Если папка с проектом выбрана верно, в окне импорта проекта должен появиться проект
«PCIE_exampleProject» в списке проектов, доступных для импорта (рисунок 2-6). Снимите флажок с
параметра «Copy projects into workspace» (если он установлен) и нажмите кнопку «Finish».

2.3 Сборка проекта
В левой части главного окна находится окно «Project Explorer», в котором должен находиться только один
проект «PCIE_exampleProject». Нажмите правой кнопкой мыши на названии проекта, и в появившемся меню
выберите пункт «Build Project» (рисунок 2-7).

Примечание

Если окно «Project Explorer» отсутствует, его можно открыть, выбрав пункт меню «View > Project Explorer».
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Рисунок 2-6: Окно импорта проекта

Рисунок 2-7: Выбранный пункт меню сборки проекта

Примечание

Сборку проекта можно выполнить путем выбора пункта главного меню «Project > Build Project».

Будет запущен процесс сборки проекта, ход которого будет отображаться в окне, показанном на рисунке 2-8.

В случае успешной сборки проекта тестовой программы, в окне консоли (Console) должны быть выведены
сообщения, идентичные показанным на рисунке 2-9.
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Рисунок 2-8: Окно, отображающее ход процесса сборки проекта

Рисунок 2-9: Окно, отображающее ход процесса сборки проекта

Примечание

Если окно консоли отсутствует, его можно открыть, выбрав пункт меню «View > Console».
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3 Конфигурация XDS100

Для загрузки и запуска тестовой программы потребуется два модуля SAMC-403. Загрузка программы в мо-
дуль осуществляется посредством эмулятора XDS100. Так как работа будет производиться сразу с двумя
отладчикам, система CCS должна идентифицировать каждое устройство. Идентификация устройств будет
происходить по серийным номерам XDS100 эмуляторов на плате SAMC-403.

Перед выполнением нижеописанных действий, на обоих модулях SAMC-403 необходимо установить пе-
реключатели в соответствии с таблицей А-1 (см. приложение А), установить модули в шасси, подключить
отладчики XDS100 обоих модулей к компьютеру USB кабелями и включить модули.

Внимание

Следет иметь в виду, что один из модулей SAMC-403 должен работать в режиме RC. Для правильной работы
модуля, необходимо на коммутаторе SMCH-100-PE установить переключатель S2 в требуемое положение
(см. приложение А, таблица А-2). Значение переключателя S2 коммутатора SMCH-100-PE должно
соответствовать номеру того AMC-слота, в который установлен модуль SAMC-403, который должен работать в
режиме RC. Номер AMC-слота установки второго модуля SAMC-403, работающего в режиме EP, не имеет
значения.

В составе среды CCS имеется утилита, которая позволяет просматривать серийные номера подключенных
к системе эмуляторов XDS100. Для запуска утилиты запустите командную строку Windows1 и выполните в
ней следующие команды:

cd "C:\Program Files\Texas Instrumens\ccsv5\ccs_base\common\uscif"
xds100serial

Результатом выполнения данных команд будет вывод списка подключенных к системе эмуляторов XDS100
с их серийными номерами (рисунок 3-1).

Рисунок 3-1: Серийные номера, подключенных к системе, эмуляторов XDS100

В случае, если оба эмулятора XDS100 имеют одинаковые серийные номера, руководствуйтесь информа-
цией, приведенной в приложении B, для изменения серийного номера одного из эмуляторов.

Далее, полученные серийные номера эмуляторов XDS100 необходимо привязать к целевым конфигура-
циям (Target Configuration) в проекте тестовой программы. Для этого, в CCS, нужно выбрать пункт ме-
ню «View > Target Configurations». В правой части главного окна откроется окно целевых конфигураций
«Target Configurations» (рисунок 3-2).

В этом окне, в дереве конфигураций, необходимо раскрыть узел «Projects», а в нем узел <PCIE_-
exampleProject». В раскрытом узле «PCIE_exampleProject» будет две целевые конфигурации проекта:

• «EP_TargetConfiguration.ccxml» — конфигурация для модуля SAMC-403, работающего в режиме EP
устройства;

1 Командную строку в Windows можно вызвать несколькими способами:
• нажатием сочетания клавиш Win+R и введя в появившемся окне команду cmd;
• выбрав пункт меню «Пуск > Выполнить...» и введя в появившемся окне команду cmd;
• выбрав пункт меню «Пуск > Все программы > Стандартная > Командная строка».
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Рисунок 3-2: Окно целевых конфигураций

• «RC_TargetConfiguration.ccxml» — конфигурация для модуля SAMC-403, работающего в режиме RC.

Для редактирования целевой конфигурации, щелкните двойным щелчком по её имени в окне
«Target Configurations». Откроется окно редактирования целевой конфигурации, показанное на рисунке 3-3.

Рисунок 3-3: Редактирование целевой конфигурации

В нижней части окна, нажмите на вкладку «Advanced» для перехода в режим редактирования дополни-
тельных параметров. В данном режиме, будет выведено дерево компонентов целевого устройства, в корне
которого расположен эмулятор XDS100 («Texas Instruments XDS100v1 USB Emulator_0»). Щелкните левой
кнопкой мыши по нему. В правой части будут выведены настраиваемые параметры эмулятора (рисунок 3-4).
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Рисунок 3-4: Редактирование целевой конфигурации, параметры эмулятора XDS100

Для возможности ввода серийного номера эмулятора XDS100, необходимо параметру «Emulator Selection»
установить значение «Select by serial number» и вписать в поле ввода «– Enter the serial number» серийный
номер требуемого эмулятора. После ввода серийного номера, нажмите на кнопку «Save».

При вводе серийных номеров эмуляторов XDS100 важно не ошибиться и ввести данные корректно. В це-
левую конфигурацию «RC_TargetConfiguration.ccxml» необходимо вводить серийный номер эмулятора того
модуля SAMC-403, который будет работать в режиме RC. Соответственно, в целевую конфигурацию «EP_-
TargetConfiguration.ccxml» необходимо вводить серийный номер эмулятора того модуля SAMC-403, кото-
рый будет работать в режиме EP.

Примечание

Проверить правильность установки серийных номеров можно с помощью тестирования соединения с эмулятором XDS100
(кнопка «Test Connection» на рисунке 3-4) при отключенном одном из эмуляторов (достаточно отключить USB кабель от
одного из устройств). Выполнять тестирование можно только после сохранения конфигурации (кнопка «Save»).
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4 Загрузка и инициализация тестовой программы

Для загрузки тестовой программы в память модулей SAMC-403 потребуется запуск второй копии среды
разработки CCS с отдельным рабочим пространством.

Первая копия среды CCS с рабочим пространством «Workspace_RC» (создание рабочего пространства
«Workspace_RC» описано в разделе 2.1) будет использоваться для работы с модулем SAMC-403, работа-
ющим в режиме RC. Вторая копия среды CCS с рабочим пространством «Workspace_EP» (процесс созда-
ния рабочего пространства описан в разделе 4.1) будет использоваться для работы со вторым модулем
SAMC-403, работающим в режиме EP устройства.

4.1 Создание второго рабочего пространства
Запустите вторую копию среды разработки CCS. При запуске будет отображено окно выбора рабочего про-
странства (рисунок 4-1).

Рисунок 4-1: Окно выбора рабочего пространства при запуске CCS

Введите в поле ввода «Workspace:» путь к рабочему пространству («D:/PCIE/Workspace_EP») и нажмите
на кнопку «OK». Будет создано новое рабочее пространство «Workspace_EP». Далее, выполните импорт
проекта тестовой программы в рабочее пространство, как описано в разделе 2.2.
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4.2 Запуск целевых конфигураций
Для запуска целевой конфигурации модуля SAMC-403, работающего в режиме RC, выполните действия,
описанные в процедуре 4-1.

Процедура 4-1. Процедура подключения к модулю SAMC-403, работающему в режиме RC

1. Перейдите в копию CCS с рабочим пространством «Workspace_RC».
2. Откройте окно «Target Configurations» (меню «View > Target Configurations»).
3. Нажмите на целевой конфигурации «RC_TargetConfiguration.ccxml» правой кнопкой мыши. В

появившемся контекстном меню выберите пункт «Launch Selected Configuration» (рисунок 4-2).

Рисунок 4-2: Запуск целевой конфигурации

Аналогично процедуре 4-1, для запуска целевой конфигурации модуля SAMC-403, работающего в режиме
EP, выполните действия, описанные в процедуре 4-2.

Процедура 4-2. Процедура подключения к модулю SAMC-403, работающему в режиме EP

1. Перейдите в копию CCS с рабочим пространством «Workspace_EP».
2. Откройте окно «Target Configurations» (меню «View > Target Configurations»).
3. Нажмите на целевой конфигурации «EP_TargetConfiguration.ccxml» правой кнопкой мыши. В

появившемся контекстном меню выберите пункт «Launch Selected Configuration».
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4.3 Подключение к процессорам
После запуска целевой конфигурации, среда разработки CCS перейдет в режим отладки, в котором появят-
ся дополнительные отладочные окна (рисунок 4-3).

Рисунок 4-3: Главное окно CCS в режиме отладки

После выполнения запуска целевых конфигураций, необходимо выполнить подключение первому ядру про-
цессора C6678. В окне «Debug» будет выведен список ядер процессора C6678. Нажмите правую кнопку мы-
ши на первом ядре (самое верхнее). В появившемся контекстном меню выберите пункт «Connect Target»
(рисунок 4-4). Данное действие необходимо выполнить для обоих копий среды разработки CCS.

Рисунок 4-4: Подключение к ядру процессора C6678
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При успешном выполнении подключения к ядру процессора C6678, в консоль должна быть выведена ин-
формация об инициализации ядра, как показано на рисунке 4-5.

Рисунок 4-5: Вывод в консоль при успешном подключении к ядру процессора C6678
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4.4 Загрузка программы
После выполнения подключения к ядрам процессора на обоих модулях, в память ядер необходимо загру-
зить собранную тестовую программу (см. раздел 2.3). Для выполнения загрузки программы нажмите на
кнопку загрузки программы (выделена красным кругом на рисунке 4-6).

Рисунок 4-6: Кнопка загрузки программы в память ядра

Откроется окно загрузки программы, показанное на рисунке 4-7, в котором можно выбрать файл бинарного
образа программы для загрузки.

Рисунок 4-7: Окно загрузки программы

Нажмите на кнопку «Browse project...». Откроется окно выбора бинарного образа программы для загрузки
(рисунок 4-8). В этом окне, в дереве «PCIE_exampleProject» нужно выбрать образ «PCIE_exampleProject.out»
и нажать на кнопку «OK». В окне загрузки программы (рисунок 4-7) также нажать на кнопку «OK».

Рисунок 4-8: Окно выбора бинарного образа программы для загрузки
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Начнется процесс загрузки программы в память ядра процессора C6678. После завершения загрузки про-
граммы, окно «Debug», в котором отображается список ядер процессора C6678 примет вид, показанный на
рисунке 4-9.

Рисунок 4-9: Окно «Debug» после загрузки программы

Действия по загрузке программы необходимо выполнить для обоих копий среды разработки CCS.

Далее, только для среды разработки, подключенной к модулю SAMC-403, который работает в режиме EP
устройства, необходимо выполнить действия описанные ниже.

Нажмите правой кнопкой мыши в любом месте области, в которой отображается исходный код программы.
Появится контекстное меню, показанное на рисунке 4-10.

Рисунок 4-10: Контекстное меню области исходного кода программы

Выберите пункт меню «Add Watch Expression...». В открывшемся окне ввода выражения для наблюдения
(рисунок 4-11) введите в поле «Expression to watch:» значение «PcieModeGbl» соблюдая регистр вводимых
символов. Нажмите на кнопку «OK».

Рисунок 4-11: Окно ввода выражения для наблюдения
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В окне наблюдения за выражениями (Expressions) появится введенное («PcieModeGbl») выражение (рису-
нок 4-12). Измените значение выражения с «pcie_RC_MODE» на «pcie_EP_MODE». Значение выражения
«PcieModeGbl» можно изменить щелкнув на текущее значение выражение (столбец «Value»).

Рисунок 4-12: Окно наблюдения за выражениями

Примечание

Если окно наблюдения за выражениями (Expressions) не открыто, его можно открыть выбрав пункт меню
«View > Expressions».
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5 Запуск тестовой программы

Перед выполнением процедуры запуска тестовой программы на модулях SAMC-403 необходимо выполнить
действия, описанные в разделах 2 и 4. Сборку программы (раздел 2) достаточно выполнить один раз.

Сначала запускается программа загруженная на модуль SAMC-403, работающий в режиме EP устройства.
Для запуска программы необходимо нажать на кнопку запуска программы (выделена красным кругом на
рисунке 5-1).

Рисунок 5-1: Кнопка запуска программы

При успешном запуске программы, в консоль должны быть выведены данные, показанные на рисунке 5-2.

Рисунок 5-2: Кнопка запуска программы

После запуска программы на EP устройстве, можно запускать программу, загруженную на модуль
SAMC-403, который работает как RC). Для этого, в соответствующей копии среды CCS, нажмите на кнопку
запуска программы (см. рисунок 5-1).

При успешном запуске программы, в консоль должны быть выведены данные, аналогичные показанным на
рисунке 5-3.
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Рисунок 5-3: Вывод в консоль при запуске программы RS устройства

При этом, в консоли EP устройства должна появиться информация о том, что данные успешно получены
от RC устройства и отправлены обратно (рисунок 5-4).

Рисунок 5-4: Завершение тестовой программы на консоли EP устройства

Полученные данные, аналогичные показанным на рисунках 5-3 и 5-4 свидетельствуют об успешной пере-
даче данных между двумя модулями SAMC-403.
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Приложение А Аппаратная конфигурация

Таблица А-1: Положение переключателей модуля SAMC-403 для включения режима работы с PCI-E

Переключатель 1 2 3 4

SW3 OFF ON ON OFF

SW4 ON ON ON ON

SW5 ON ON ON OFF

SW6 OFF ON ON ON

SW9 OFF ON — —

Таблица А-2: Положение переключателей S2 коммутатора SMCH-100-PE для выбора AMC-слота, который будет назначен
upstream портом PCI-E

AMC1 AMC2 AMC3 AMC4 AMC5 AMC6 AMC7 AMC8 AMC9 AMC10 AMC11 AMC12
SW2:1 ON ON OFF OFF OFF ON ON ON ON OFF ON ON

SW2:2 ON ON ON ON OFF OFF ON OFF OFF OFF OFF ON

SW2:3 OFF ON ON ON ON OFF ON ON ON ON OFF OFF

SW2:4 ON OFF ON OFF OFF ON ON ON OFF ON OFF OFF

Внимание

Таблица положений переключателя S2, напечатанная на самой плате коммутатора SMCH-100-PE не верная.

Соответствие номеров AMC-слотов в 1U шасси производства компании MicroBlade с их физическим распо-
ложением в шасси показано на рисунке А-1.

Рисунок А-1: Расположение AMC-слотов в шасси MicroBlade 1U

Соответствие номеров AMC-слотов в 2U шасси производства компании MicroBlade с их физическим распо-
ложением в шасси показано на рисунке А-2.

Рисунок А-2: Расположение AMC-слотов в шасси MicroBlade 2U
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Приложение Б Изменение серийного номера XDS100

Для изменения серийного номера эмулятора XDS100 используется программа FTDI FT Prog. Програм-
му FTDI FT Prog версии 2.6.8 можно найти на сопроводительном диске к модулю SAMC-403 в папке
«software/ftdi». Скачать последнюю версию программу можно по ссылке http://www.ftdichip.com/Resources/
Utilities.htm.

Запустите программу FTDI FT Prog. В открывшемся главном окне выберите пункт меню
«Devices > Scan and Parse» или нажмите клавишу F5. Будет выполнено чтение информации из EEPROM
всех доступных устройств XDS100.

После выполнение чтения данных из EEPROM устройств, раскройте узел «USB String Descriptors»
одного из устройств, например, устройство «Device: 0» (рисунок Б-1). Выберите в раскрытом узле
«USB String Descriptors» параметр «SerialNumber».

Рисунок Б-1: Главное окно программы FTDI FT Prog

В правой части окна программы FTDI FT Prog будет отображена текущая информация о серийном номере
устройства. Для его изменения, снимите флажок с параметра «Auto Generate Serial No:», и впишите в поле
ввода «Serial Number:» значение нового серийного номера устройства.

Для записи измененной информации обратно в EEPROM устройства, выберите пункт меню
«Devices > Program» или нажмите сочетание клавиш Ctrl+P.

После завершения записи в устройство, для применения сделанных изменений, необходимо выключить
устройство и снова включить.
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